7shifts Support unavailable via phone
Incident Report for 7shifts
Resolved
7shifts support phone provider has resolved the issue preventing us from taking support calls.

7shifts phone support is back online.
Posted Apr 22, 2024 - 11:20 CST
Investigating
7shifts support phone provider is currently down, which is impacting our team's ability to offer phone support at this time.

Our team is still available to support customers on live chat. To access live chat, log in to your 7shifts account, and click the '?' icon at the bottom-right of the page.

We will continue to provide updated here.

For more on this issue, use the link below to access our phone provides status page.

https://status.zendesk.com/
Posted Apr 22, 2024 - 10:39 CST